well I started with linux a few days ago but had worked with UNix on an NT server before but I am really stuck now. I have MAndrake 7.2 and usually it would start up and then show the shell login but that would dissapear and the GUI for linux would start up but once time i quit to console and now when I start up it just goes straight into the shell, I have tried kstart which I was told could start kde up again but all it said was cannot connect to X server

plz help :frowning:


Have you tried to shut down the server and reboot?

If you shut down and reboot and the problem persists, you have changed something which does not allow the Xserver to communicate or startup. There can be many reasons for this including network permissions or Xserver configuration errors.

hmm well I havent changed any set ups and have tried init 5 which is meant to do it but as it loads the screen flickers and returns to the shell, I have tried rebooting and shutdown etc but are there any flags I should add to it that would start up the GUI and the nice colourful linux screen again? :slight_smile:


I would contact Mandrake directly. Did you try calling or writing them?

The reason I suggest calling them is that debugging X problems take a lot time and it will be hard to do over the forum. Lots of files are required, including logfiles, network related files, X server config files.

It might just be easier for you do to a complete reinstall of the Mandrake software.

You could also use the FIND command to look at all the files that changed after it was working (look at the manpage on FIND for this) and see what configuration files might have been accidentally changes.

well after much looking round on the mandrake site it gave me a url to a help site ;

there they had some X setup tips and tried setup and things then I tried the startx command and it did what init 5 usually does but it showed an error after it failed saying it couldnt load a font and now I think before I restarted I did change the font, is there anyway I can change the font selection or setup?

thanks again :slight_smile:

Yes, not being able to find the a font could cause X to die. You need to find the X config file for the X server and change the font entry to one the system recognizes or exists (or find the fonts you choose and install them).

This is not a very easy task. Font packages are difficult, but you might be able to do it with patience :slight_smile:

If you have not installed a lot of custom software, it might easier to do a new Mandrake install and be more conservative about changing default fonts. That might actually be faster than chasing down the font error.

If you are brave and want to try fixing it. Go to the directory /usr/lib/X11 and look the XF86Config.* files and start from that file and directory. Be careful. It is easy to make a mistake here that is hard to correct.

You probably dont need to reinstall the whole system, just the missing font packages. Anyway, take alook at the bottom of this page:

It seems to be describing exactly your problem. Good luck.


well I did try reinstalling at the very start before all of this but it said I didnt have enough memory but after some fiddling I just managed to install it again :slight_smile:

thanks for the help and now I know where to come for help in future :slight_smile:
its things like this which help us "Newbies" get to know unix, I know now more about unix that I did a day ago :slight_smile: