Print not carriage returning

We have a Canon GP215 that when printing a unix dump to will only print one line the whole page would appear on the line if the page was long enough,
I have been told it is because there are no carriage return triggers
where do I look and how do I rectify the problem????

The printer is not responding the the end-of-line and line-feed symbols in the file. You might consider checking the printer settings and insure that the printer will recognize the control character in the file. You need to know exactly what is the control character used, i.e. CRLF, in the file and insure that the printer will take the right action when receiving the control character. I assume the file is ASCII text?

This is very common when printing from Unix.
you need to pipe your file before printing it into the command "unix2dos" it adds carridge returns to each line.
or if you don't have this command use :
awk '{print $0,"\r"}'
to get the same result.
for example :
cat file | unix2dos | lp -d printer1
cat file |awk '{print $0,"\r"}' | lp -d printer1


Thanks Guys,
Great response from both me2unix & Neo which seems to have solved the problem. I will post a definate reply shortly.