Dleting a Device in AIX 4.3

I need to delete a TTY in my AIX 4.3 system. I have tried using the smit but everytime I try it, there is a message telling me that the device is in use and cannot be changed. How do I take the device "offline", so to speak, so that I can edit the settings and/or delete it.



The 'device in use' error comes from the fact that there is a process running which has an open/active file descriptor associated with the device. You must determine the process(es) which is(are) associated with the device and kill it(them).

If the device is a tty then you have to determine which tty is in use (mouse, modems, console, logins, etc) and make sure when you kill the process that you are not killing the shell you are working in. For example, if you are at a console and logged in to the system, you cannot kill that tty. If you do, you will be kicked off, because your shell process (associated with the tty) will die.

Enjoy the detective work! It not too hard of a detective-problem and should be rewarding finding out which TTYs are associated with what process :slight_smile:

I ran the ps -A command to display all the processes but I did not find any process associated with the TTY that I want deleted (TTY15) A serial Terminal interface. I don't want to kill processes arbitrarily.

Well, I found the solution.

I used the pdisable command and took the TTY in question "off-line". And then used smit to edit and delete the TTY finally.

Thanks though, Neo.