How to increase or decrease inode number of the particular UFS filesystem

Hi Gurus

I want to know the command & tips regarding, how to increase or decrease inode number of the particular ufs filesystem. Is it possible to do it in a live/production environment.

Regards

use:

newfs -i <nbpi>

see newfs(1M) - construct a new UFS file system (man pages section 1M: System Administration Commands) - Sun Microsystems

UFS sets a fixed percentage of the disk to be inodes at the time the filesystem is created.

The only way to add more inodes to a UFS filesystem is:

  1. destroy the filesystem and create a new filesystem with a higher inode density
    (newfs -i)

  2. enlarge the filesystem - growfs man page
    (if you increase capacity by 50%, you get about 50% more inodes as well).

df -o i filesystem

shows the inode status for a UFS filesystem.

You can limit the number of inodes used on a per user basis.
Set Diskquota in Solaris

thanks a ton for kind & knowledgeable replies.

regards