Unable to mount NFS

Hello,

While mounting NFS below error is coming:

[root@cindb1002a ~]# mount -t nfs 10.65.150.69:/lvsnap /lvsnap
mount: mount to NFS server '10.65.150.69' failed: RPC Error: Program not registered.

Please advise.

Best regards,
Vishal

There are a number of things that could go wrong? What have you tried? Can you ping the server? What does showmount -e 10.65.150.69, how about showmount -a 10.65.150.66? What operating systems are involved? Are all the server processes running? Has this ever worked?

There was issue in permission of /etc/hosts.allow and /etc/hosts.deny
I changed this to 644 from 600.
After changing this gave another error as below:

Feb  5 15:11:23 cindb1003a mountd[30834]: refused mount request from 10.65.150.68 for /lvsnap (/lvsnap): unmatched host
Feb  5 15:11:23 cindb1003a mountd[30834]: refused mount request from 10.65.150.68 for /lvsnap (/lvsnap): unmatched host

I changed /etc/exports from

[root@cindb1003a ~]# cat /etc/exports
/lvsnap 10.65.150.*(rw)

to

[root@cindb1003a ~]# cat /etc/exports
/lvsnap 10.65.150.0/24(rw,sync)

This worked.

Best regards,
Vishal

---------- Post updated at 04:42 PM ---------- Previous update was at 04:40 PM ----------

But still not sure what is /24

Regards,
Vishal