Having trouble with REISERFSCK

I am having some problems with a Reiserfs partitioned drive on my Suse 9.2 server.

I run reiserfsck:-

# reiserfsck --fix-fixable /dev/hdi1

and I get:-

Partition /dev/hdi1 is mounted with write permissions, cannot check it

so I remount as Read-Only using:-

# mount -o remount,ro /dev/hdi1

and run reiserfsck again:-

# reiserfsck --fix-fixable /dev/hdi1

reiserfsck --fix-fixable started at Sun Oct 16 18:18:41 2005
###########
Filesystem seems mounted read-only. Skipping journal replay.
--fix-fixable ignored

Checking internal tree../ 2 (of 3)/ 88 (of 148)/ 76 (of 170)bad_indirect_item: block 58960179: The item [564 572 0x3404e001 IND (1)] has the bad pointer (239) to the block (4096)
bad_indirect_item: block 58960179: The item [564 572 0x3404e001 IND (1)] has the bad pointer (240) to the block (227422208)
bad_indirect_item: block 58960179: The item (564 572 0x3404e001 IND (1), len 3188, location 908 entry count 0, fsck need 0, format new) has the bad pointer (241) to the block (23529627), which is in tree already
bad_indirect_item: block 58960179: The item (564 572 0x3404e001 IND (1), len 3188, location 908 entry count 0, fsck need 0, format new) has the bad pointer (242) to the block (23529628), which is in tree already
bad_indirect_item: block 58960179: The item (564 572 0x3404e001 IND (1), len 3188, location 908 entry count 0, fsck need 0, format new) has the bad pointer (243) to the block (59173507), which is in tree already
bad_indirect_item: block 58960179: The item (564 572 0x3404e001 IND (1), len 3188, location 908 entry count 0, fsck need 0, format new) has the bad pointer (244) to the block (59173508), which is in tree already
bad_indirect_item: block 58960179: The item (564 572 0x3404e001 IND (1), len 3188, location 908 entry count 0, fsck need 0, format new) has the bad pointer (261) to the block (59173534), which is in tree already
finished
Comparing bitmaps..vpf-10640: The on-disk and the correct bitmaps differs.
Checking Semantic tree:
finished
9 found corruptions can be fixed when running with --fix-fixable
###########
reiserfsck finished at Sun Oct 16 18:21:57 2005
###########

So there are clearly errors I need to fix.

Remounting as Read-Write again

# mount -o remount,rw /dev/hdi1

means that reiserfsck can't check the volume.

Does anyone have an idea what I'm doing wrong? Or how I can fix these errors?

Many thanks,

Mark.

I would try this: unmount it, fsck it, then mount it.

Still didn't work :confused:

It appear to run reiserfsck anyway, even though I type "fsck".

I got impatient in the end and ran the apparantly more risky
"reiserfsck --rebuilt-tree" which took a long time but fixed the problem nicely.

Any idea why it refused to run the --fix-fixable?

Thanks anyway,

Mark.