Unix Internet Connection

I am trying to set up my internet connection for my unix system and cannot seem to do it. I have a optimum on line service, and use a cable modem, with a usb. The 3 com ethernet card in my Gateway Labtop is recognized but when I hook up the usb and try and connect the usb is unrecognized. I have tried to change the IP address and domaine name but it does not work seeing as I don't really know how to do so. Is it just a matter of changing the IP address? Can anyone help? Thank you in advance,

Monkette

OH yeah and I'm using Red Hat, Linux 7 Kernel 2.2.16-22 thanks again if anyone can help. I do have the domaine name and server number.

[Edited by kdelph on 04-05-2001 at 05:45 PM]

Here is a page I put together for a friend of mine some time ago detailing how to configure a Linux box for $Home service.
http://www.1le.net/~1le/linux/
I'm not sure what you are using the USB port for. You will need a crossover cable between the hub/cable modem and a straight through cable between the NIC in the PC and the hub. I hope this helps.

Thank you for your help only problem is that I'm using KDE instead of GNOME, any suggestions? Thanks again.

This address was a great help but it is still not working, when I try and act the changes I have made setting up my IP Address etc. I get this message error cannot act changes things to do :

Executing: \etc\rc3.d\s60lpd start

I have no clue what this means and also when I boot up I get a failed message for

Bringing up interface eth0: Delaying eth0 initialization

[failed]

I'm not sure this must mean my card is not working or set up properly any suggestions on what I can do?

Thanks Monkette

This is actually not a failure in Redhat(on laptop). it means that this network interface will not be initialized until after the PCMCIA network device is configured. Networking seems to work OK despite the message.

It's caused by Linux trying to start the network interface before it loads the PCMCIA drivers. You can overcome this by changing a couple of entries in /etc/rc.d/rc3.d (if you boot direct to X then rc5.d) simply rename SXXpcmcia script to SNNpcmcia script where NN is a lower number than SXXnetwork. so that pcmcia script now run before network script.

if you are not familiar with rc.d scripts you should avoid playing with it and ignore this failure message(network is OK). and if you think network is not working there may be number of reason. please check /var/log/messages file and see whether anything is being logged that is regarding delaying of the eth0. and please post those errors here.

ThanX

When I went to the rc3.d directory the PCMCIA was S45PCMICIA
in the rc3.d directory it was the same there is also a file called S60lpd in both which is what has been givng me problems. I'm not sure weather to compy the S45PCMICIA and name it SNNPCMCIA and then delete the other one or what to do???

As for the var/log/messages

When I type it it says bash: /var/log/messages: Permission denied.

I am logged on as Root

Any suggestions? Thanks

File log messages is a text file. You cannot read it by executing /var/adm/messages from the command line.

To view /var/adm/messages, you must either use an editor (like vi, emacs) or use another tool such as more or (believe-it-or-not) the less command.

Try:

more /var/adm/messages

Ah ha, there we go ok

local host Kernel Error: Illegal request --(sense Key=0x05)

local host Kernel Invalid field in command packet -- casc=0x24,ascq=0x00

local host Kernel The Failded "Start/Stop Unit" Packet command was:

local host kernel "lb 00 00 00 03 00 00 00 00 00 00 00"

Error in command packet byte 4 bit0

hdc: packet command error: error = 0x54

There are the error's or failure's I found when I VI'd the log messages, thanks this is a great site Linux is hard to learn and you guys help so much :slight_smile:
Any suggestions?

check your BIOS. your PCMCIA bridge must be set to PCIC mode in your BIOS setup. Do not use Cardbus/16-bit or auto-detect.

thanX

How do I check my BIOS? I have tried looking in the linuxconf and in my etc/rc.d files but find nothing? I'm extremely new at all this and am slowly learning have to say it is fun and this site is a big help. Thanx.

Monkette :slight_smile:

Ok. so you couldn't find BIOS in these directory. never mind. I will tell you how to access BIOS in your computer.

The BIOS(Basic Input Output System) is built-in software that determines what a computer can do without accessing programs from a disk(HDD, FDD, CD). BIOS gives the computer a little built-in starter kit to run the rest of softwares from hard disks (or FDD, CD). The BIOS is responsible for booting the computer by providing a basic set of instructions. It performs all the tasks that need to be done at start-up time: POST (Power-On Self Test, booting an operating system from FDD or HDD). Furthermore, it provides an interface to the underlying hardware for the operating system in the form of a library of interrupt handlers. For instance, each time a key is pressed, the CPU (Central Processing Unit) perform an interrupt to read that key. This is similar for other input/output devices (Serial and parallel ports, video cards, sound cards, hard disk controllers, etc...).

Computers display instructions while the system is booting on how to access the system BIOS. A key usually accesses the BIOS or you will need to press a combination of keys before the Operating System begins to load. Some common keys are ESC, F1, F2, F10, Ctrl-Del, or Del. For more information, check the documentation that came with your computer.

I think for gateway it is F1 Key(or whatch your monito while system boots up. it will show press <Key> to enter setup.)

ok now now press F1 key while system boot. yep you are there. now all things are menu driven and easy follow.

now set Controller Mode in PC CARD section to PCIC Compatible. Also disable PNP(Plug 'n Pray :slight_smile: ). it is in PNP section. now save all changes and reboot system. if it gives same error in system log(or any error) come back to us. let us see how far we can go!

read http://linuxdoc.org/HOWTO/PCMCIA-HOWTO.html

Ok On my system it is f2,

I disabled the PNP but can not set the controller Mode as there is no PC Card Section though when in KDE I look at PCI there is a PCI Bridge. I'm not sure how to access the controller mode to change to PCIC Compatible. I have tried to log on to the internet anyhow and of course no go, I am still getting this error cannot activate changes:
(meaning I cannot change the IP address, netmask, etc.)
Error things to do:

Executing \etc\rc3.d\S60lpd start.

I am also getting this message when I boot up lpd initialized but then lpd 2001-04-17-08:42.20.002 Get_Local_Host hostname webmaster.frenchiephotos bad

then when I shut down I get these errors:

Stopping lpd failed.

I have to somehow fix this error to be able to change the IP address to the correct one. I think I'm typing in my hostname the wrong way as well. I don't really have a hostname I know in Window's you don't even need one, do they mean the adapter address instead of hostname? Thanks for all your help, I really appreciate it!! :):slight_smile:
Turning off swap failed.

Did you add the new name and IP to /etc/hosts
it's entry should be something like this.

127.0.0.1 ����� localhost
192.168.1.1 ����� webmaster ����� webmaster.frenchiephotos.com

HTH

ok figured out how to set the etc/host and it is correct but still the same problem with the executing error.

All of the errors are gone I don't know exactly what I did I played around I reset something in the etc/hosts and there are no more errors!! I just have to wait for my lunch break go home and try to hook up to the internet I'll let you know what happens.
thanks for all your help.

Monkette

Ok I went home and tried it but the cable box does not light up well the pc part anyhow when I try and connect I have tried with a crossover cable and a normal network cable still no go. I'm wondering if there's something I must set up on my computer? I'm also going to call the cable people and see if it's something they must do on their end. Any suggestions?
Thanks.

[Edited by kdelph on 04-19-2001 at 03:21 PM]