# Unable to mount NFS

**URL:** <https://community.unix.com/t/unable-to-mount-nfs/350184>\
**Category:** UNIX for Dummies Questions & Answers\
**Created:** [February 5, 2015, 2:53pm UTC](https://community.unix.com/t/unable-to-mount-nfs/350184 "2015-02-05T14:53:55Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![admin\_db](https://community.unix.com/letter_avatar/admin_db/32/5_5575768a8748004e209b776fc1b2916d.png) [@admin\_db](https://community.unix.com/u/admin_db)\
**Post date:** [February 5, 2015, 2:53pm UTC](https://community.unix.com/t/unable-to-mount-nfs/350184/1 "2015-02-05T14:53:55Z")

</div>

Hello,

While mounting NFS below error is coming:

```nohighlight
[root@cindb1002a ~]# mount -t nfs 10.65.150.69:/lvsnap /lvsnap
mount: mount to NFS server '10.65.150.69' failed: RPC Error: Program not registered.

```

Please advise.

Best regards,  
Vishal

---

<div class="post-metadata">

**Author:** ![blackrageous](https://community.unix.com/user_avatar/community.unix.com/blackrageous/32/2911_2.png) [@blackrageous](https://community.unix.com/u/blackrageous)\
**Post date:** [February 5, 2015, 4:04pm UTC](https://community.unix.com/t/unable-to-mount-nfs/350184/2 "2015-02-05T16:04:52Z")

</div>

There are a number of things that could go wrong? What have you tried? Can you ping the server? What does showmount -e 10.65.150.69, how about showmount -a 10.65.150.66? What operating systems are involved? Are all the server processes running? Has this ever worked?

---

<div class="post-metadata">

**Author:** ![admin\_db](https://community.unix.com/letter_avatar/admin_db/32/5_5575768a8748004e209b776fc1b2916d.png) [@admin\_db](https://community.unix.com/u/admin_db)\
**Post date:** [February 5, 2015, 4:42pm UTC](https://community.unix.com/t/unable-to-mount-nfs/350184/3 "2015-02-05T16:42:27Z")

</div>

There was issue in permission of /etc/hosts.allow and /etc/hosts.deny  
I changed this to 644 from 600.  
After changing this gave another error as below:

```nohighlight
Feb 5 15:11:23 cindb1003a mountd[30834]: refused mount request from 10.65.150.68 for /lvsnap (/lvsnap): unmatched host
Feb 5 15:11:23 cindb1003a mountd[30834]: refused mount request from 10.65.150.68 for /lvsnap (/lvsnap): unmatched host

```

I changed /etc/exports from

```nohighlight
[root@cindb1003a ~]# cat /etc/exports
/lvsnap 10.65.150.*(rw)

```

to

```nohighlight
[root@cindb1003a ~]# cat /etc/exports
/lvsnap 10.65.150.0/24(rw,sync)

```

This worked.

Best regards,  
Vishal

---------- Post updated at 04:42 PM ---------- Previous update was at 04:40 PM ----------

But still not sure what is /24

Regards,  
Vishal
