no $ prompt while starting console

I had this problem before but it started working OK for a while. I can create a new profile but when I launch the console for that user it does not show the $ prompt. It shows for su and I tried to set the terminal but I am not sure if I did it correctly since it does not work still. The terminal runs OK. This is on Solaris 8.
Appriciate your help, George

any idea why that might be?
Thanks, George

I'm not clear on your question. Is the user getting a shell? Can they execute commands? If so what are the results from:

echo $PS1
echo $SHELL

Well, on the bottom bar I pop-up the selection from which I launch the console on solaris 8. The console or the window comes up but it takes 60 seconds (I just measured that) for the $ to come up. Then I can type commands. I an type anything in but it does not do anything until the 60 seconds when it resolve itself.
When I log in like another user the system takes like 2 minutes to come up. It's like trying to resolve something. It did not do that before. Did I mess up the system so much that it takes it so much to resolve its setup?
Thank you, George

add the line:
set -x

to your .profile. This should show you in great detail which commands are being run as you start up the shell.

+ export PATH
+ tty
+ [ /dev/pts/4 = /dev/console ]

That's the output.
Thanks, George

The problem you are discussing may be an X related profile issue vs. the shell profile. Most X systems have a different set of profiles which are executed which are in the X paths vs. the /etc/profile and .profile under discussion.

I suggest that it is necessary to understand the full sequence of events after you launch an X console, e.g. all the resource files and their sequence and debug step-by-step. Does this make sense to you?

Yes, I do understand what you are saying and I look into the creation of the new profile. The thing is, that this is the same profile that was initially working fine and now it takes so long to load the console environment.
I let you know what I come up.
Thank you, George

Understood. One suggestion is that the delay could because by an X related networking issue. Keep in mind that all these X consoles use the network, either loopback as localhost and/or as external TCP/IP sockets. When there is a delay in bringing up an X term, it is often network related (X authentication, network problems, etc.) Did you make any changes to your network config lately?

Well, I verified all the addressing and I also ran the file system check command and when I rebooted the console worked fine finally. So, I hope that this fsck fixed the problem. How often the system administrator should run the administrative tasks and what time normally that is done? I do lately lots of configurations with apache, tomcat, redoak, jrun, and etc. Then I get rid of it if something's not working right and install it again. I am not sure how much of these reinstallations can conflict with the regular system setup?
Thank you for you help, George