Need help with webcam sound

Hello Linux users. I hope someone can help me out here as I have tried many things.

I had just purchased a new web cam and plugged it in to my Linux machine which is running Pop! OS 20.04 (based on the latest Ubuntu OS). The amazon page mentioned this works with Ubuntu and the picture is great. It's just the mic I am having trouble with and only on my Linux machine.

I recorded some videos for testing, some using Cheese that was preinstalled and some using OBS Studio for Linux. When playing back the video, there is this continuous popping sound. I tried researching this and found a few items I tried.

  1. sudo apt install alsa-tools
    Created and save a script in /usr/local/bin:

#!/bin/bash
hda-verb /dev/snd/hwC0D0 0x20 SET_COEF_INDEX 0x67
hda-verb /dev/snd/hwC0D0 0x20 SET_PROC_COEF 0x3000`

Ran the script as root in a terminal.

  1. /etc/modprobe.d/alsa-base.conf
    Added the below line
    options snd-hda-intel power_save=0 power_save_controller=N

  2. Emailed the Video to someone else and the same thing happens. to me, this suggests it happens on creation of the video – perhaps I’m wrong but it’s what makes sense to me at least.

  3. Unplugged the headset/microphone and only used speakers.

  4. Unplugged speakers and only used headset.

  5. Changed 1 to 0 in /sys/module/snd_hda_intel/parameters/power_save
    Changed Y to N in /sys/module/snd_hda_intel/parameters/power_save_controller

  6. in /etc/pulse/default.pa
    changed load-module module-udev-detect
    to load-module module-udev-detect tsched=0

  7. pulseaudio -k && sudo alsa force-reload
    It sounds like horses galloping after this

  8. Using the same webcam, created a video on a windows laptop. This worked fine so the webcam and integrated microphone seems to be fine.

  9. Tried a different USB port with the same results.

  10. Note that I am able to listen to anything else with no issues. It is only when I do these actions.

A. Playing back my own video recordings on my Linux desktop.
B. When on Zoom meetings, no one is able to here me even though when I test my mic, Zoom says it is picking up sound when I am talking.

I am guessing this is a Linux issue only because there are not any issues when using the same webcam on another computer such as my son's Windows laptop. I hope there is just as setting I am missing in pavucontrol or alsamixer. Please let me know if you need any commands I need to run if you need additional output.

lspci | grep -i audio
0a:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
0a:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller
cat /proc/asound/card0/codec* | grep Codec
Codec: ATI R6xx HDMI
hostnamectl
Operating System: Pop!_OS 20.04 LTS
Kernel: Linux 5.4.0-7634-generic
lsusb
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 002: ID 18f8:0f99 [Maxxter] Optical gaming mouse
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 0bda:0411 Realtek Semiconductor Corp. 4-Port USB 3.0 Hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 0bda:5411 Realtek Semiconductor Corp. 4-Port USB 2.0 Hub
Bus 003 Device 004: ID 0c45:6366 Microdia USB Color Camera
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1209:1776 Generic Io
Bus 001 Device 004: ID 8087:0025 Intel Corp.
Bus 001 Device 002: ID 0e6a:02c0 Megawin Technology Co., Ltd PS/2+USB Keyboard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So you appear to have proved that the device isn't faulty BUT is it getting enough power from the USB port on that particular box. The first thing I'd try is connecting it via an independently powered USB hub to ensure it is getting fully powered. Before you prove that too, you might well make things worse and more problematic to sort out later by making changes to the Linux setup.

And another thought is.....is the USB speed of the webcam being negotiated down , USB3 to USB2 or USB2 to USB1 on that box?

What USB versions are (1) the webcam, and (2) the Linux box?