I'm running Digital Unix True64 system. version4.0. My CDE is shutoff. How can I start the CDE. When I boot my system I don't even get graphic startup picture in the beginn. I've tried to activate thourgh Graphical UI Selection Facility in /usr/sbin/setup.But all I have is alot of inactive processes and no CDE. Even after a reboot.

And Do have to change the /etc/initab to make the CDE start after every boot or where in the shell I have to make the changes that CDE starts everytime that reboot.

I know that before it use to work on this system.

Please Help....

[Edited by Peterh on 03-01-2001 at 02:23 AM]

You must insure that your X server environment and processes are running before CDE kicks off.

Yes X server environment and processes are running. And all the programs are installed. Some reason it doesn't run.

I'd tried useing /sbin/init.d/xlogin start that didn't work. I had to kill that process because the machine stopped running. This I got direct from Unix support.

Then I got a tip from someone to start /usr/dt/bin/dtlogin -daemon. And that did not work.

I know that shells and profiles that start the CDE but still can't see or find that keeps the CDE from starting..

Please Help again........

There may be some environmental variables that must set before CDE will start properly. Do you know what environmental variables CDE requires (LANG, DISPLAY, etc.)

For many X applications, the DISPLAY environmental must be set (and set correctly) for X to work. A quick example of the use of DISPLAY:

export DISPLAY=localhost:0.0

(as I recalloff the top of my head, please check the syntax).

Also, the host which is receiving the X application must have provided permission for the X application to run on the host (normally with the <B>xhost</B> command

[Edited by Neo on 03-01-2001 at 10:13 AM]

Help Neo,

I know but this is dumm question. Where is X applications to be found. Your example from DISPLAY could not find.

And I don't know what environmental variables CDE requires???

Note that all I know is that CDE worked before on this system and was shut off.


I don't know much about this. but i will sugest you to check error logs. i think it is /var/dt/Xerrors


That was good. I found a error.

"error (pid 926) : error 48 binding socket address 177"

Do you know this means????

thanks pete

Is this the only erorr message that's logged? Is error log says it can't Load | Find | Open any library?? If it's so please post those error message too.

also check $HOME/.xsession-errors
This file contains errors generated by your own user account.



Reading this Document will help you a lot.

In the /usr/var/X11/xdm/xdm-errors is no errors but in the xdm-pid is 998. What ever that means??? But don't have $HOME/.xsession-errors.

How about when the machine boots? Can you see any errors on the console monitor?

The machine boots without errors. But only ascci mode.

hello Neo,

I answered your question on 2-27-2001 but still got no response on CDE problem.


This message mentions the same error you are seeing (error binding socket address 177). Maybe it will help you...