can't even compile my compiler!!!

I have two systems, both running solaris 2.5.1. the first is a test server and the other is the production box.

On the test server I just compiled and installed php4, apache 1.3.17, and MySQL 3.23.32. when I tried to do it on the production box, nothing will compile and I get the following error (php4 example):

In file included from internal_functions.c:39:
/usr/local/src/php-4.0.2/ext/gd/php_gd.h:33: gd.h: No such file or directory
make[2]: *** [internal_functions.lo] Error 1
make[2]: Leaving directory `/usr/local/src/php-4.0.2/main'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/php-4.0.2/main'
make: *** [all-recursive] Error 1

I installed a new make (gnu make 3.79.1) which seemed to go ok, but did not help anything. I tried to compile a new compiler ( gcc 2.95.2 ), but guess what?


What are the error messages you receive when you try to compile gcc?

The error you noted from php is caused because the compiler cannot find a header file (gd.h) that it needs.

here are the errors that crap out the build process after about 20 minutes:

sorry for the slow image - copy and paste was f&*d for some reason.

Your gcc appears to be broken. You can get a binary to install from

i actually tried that before and don't know what to do with the file: it comes gzipped, so I unzipped it and put it in my /usr/local/bin dir (after backing up the other one), made it executable (it wasn't after downloading) and now configure scripts will not even recognize it as a functioning compiler. what am I missing here?

this is getting worse.