address in use

I get this message below and would like to fix it but I do not know how and where to look for it. Would anyone know how to fix it?
# Apr 4 14:53:23 unknown snmpdx: bind() failed on UDP port 161 [errno: Address already in use(125)]
Thank you,

This error means that you already have an application process listening on port 161. More than likely, an SNMPD is already running. To "fix it", you must kill the offending process in the process table. Suggest you do a 'ps aux' or similar ps command and check the the process table for other SNMP processes.

Well, I tried the ps but it does not show any other processes except the couple commands that I use. I am evaluating a software that is started from a console and if I close the console the software quits as well I understand that but should I be able to see the process showing its id in another console under ps command if the software is running?
Thanks, George

Well, I tried the ps but it does not show anyother processes except the commands I run. I just installed a software that runs off its console and when I go to another console to look up the running processes id does not show it in the ps table. Should the ps show every process running on the system?
Thanks, George

if 'ps aux' only shows a few commands, try 'ps -ef' instead.

Yes, this one does show all of them. Also, I just found out that the network guys changed the system servers and whatever else but they never told me that the initial addressing is absolute. I guess asking once is not enough sometimes.
Thank you for your help. George

That is exactly how it is supposed to work. To see everything, use;

ps -ef

Then type

man ps

somehow I created this thread that should be part of another thread "address in use". This is a good command 'ps -ef' as suggested in the other thread as well.
Thank you, George

merged threads --oombera